The Nissan Path Forum Index The Nissan Path
The World Wide Nissan Pathfinder Owner's Forum
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Use Google to search TheNissanPath forums ->
compass and temp display is not working

 
Post new topic   Reply to topic    The Nissan Path Forum Index -> 1996-2004 Pathfinder (R50)
View previous topic :: View next topic  
Author Message
TmacisN11



Joined: 08 Nov 2010
Posts: 5

PostPosted: Mon Nov 08, 2010 7:22 pm    Post subject: compass and temp display is not working Reply with quote

I have a 98 pathfinder and my temp and compass display isnt working and hasnt been since I bought it a couple weeks ago. Is there a common fix to these, such as soldering something or any simple fix. Im sure this has happened to many people. Any help is greatly appreciated
Back to top
View user's profile Send private message Send e-mail
fleurys



Joined: 12 May 2009
Posts: 208
Location: Ste-Catherine, QC

PostPosted: Mon Nov 08, 2010 7:28 pm    Post subject: Re: compass and temp display is not working Reply with quote

TmacisN11 wrote:
I have a 98 pathfinder and my temp and compass display isnt working and hasnt been since I bought it a couple weeks ago. Is there a common fix to these, such as soldering something or any simple fix. Im sure this has happened to many people. Any help is greatly appreciated


can you be a little more precise as to what it is doing (no display, wrong temp, weird display, etc...)

what happen when you press the button next to the display ??
Back to top
View user's profile Send private message Visit poster's website
TmacisN11



Joined: 08 Nov 2010
Posts: 5

PostPosted: Mon Nov 08, 2010 9:37 pm    Post subject: Re: compass and temp display is not working Reply with quote

fleurys wrote:
TmacisN11 wrote:
I have a 98 pathfinder and my temp and compass display isnt working and hasnt been since I bought it a couple weeks ago. Is there a common fix to these, such as soldering something or any simple fix. Im sure this has happened to many people. Any help is greatly appreciated


can you be a little more precise as to what it is doing (no display, wrong temp, weird display, etc...)

what happen when you press the button next to the display ??



it wont display at all its just black, the button next to the display.... do you mean the mode button? If you are when i press it, hold it, etc doesnt do anything
Back to top
View user's profile Send private message Send e-mail
fleurys



Joined: 12 May 2009
Posts: 208
Location: Ste-Catherine, QC

PostPosted: Tue Nov 09, 2010 9:04 am    Post subject: Re: compass and temp display is not working Reply with quote

TmacisN11 wrote:
fleurys wrote:
TmacisN11 wrote:
I have a 98 pathfinder and my temp and compass display isnt working and hasnt been since I bought it a couple weeks ago. Is there a common fix to these, such as soldering something or any simple fix. Im sure this has happened to many people. Any help is greatly appreciated


can you be a little more precise as to what it is doing (no display, wrong temp, weird display, etc...)

what happen when you press the button next to the display ??



it wont display at all its just black, the button next to the display.... do you mean the mode button? If you are when i press it, hold it, etc doesnt do anything



When there is no display at all, then it must be something easy to find like a bad or no ground or a fuse... Here's what I have found in the fsm.


Back to top
View user's profile Send private message Visit poster's website
TmacisN11



Joined: 08 Nov 2010
Posts: 5

PostPosted: Tue Nov 09, 2010 9:59 pm    Post subject: Reply with quote

I checked the fuse on no.9 and it is ok, thinking its a ground issue...that being said where is the ground circuit for the compass and thermometer located? Do I need to take down the compass/thermometer and use a voltmeter on it?
Back to top
View user's profile Send private message Send e-mail
fleurys



Joined: 12 May 2009
Posts: 208
Location: Ste-Catherine, QC

PostPosted: Wed Nov 10, 2010 5:24 am    Post subject: Reply with quote

TmacisN11 wrote:
I checked the fuse on no.9 and it is ok, thinking its a ground issue...that being said where is the ground circuit for the compass and thermometer located? Do I need to take down the compass/thermometer and use a voltmeter on it?


Yes, at one point you will have no choice but to open the compass assembly.

one easy way to see if it is the ground is to tie down a wire on the neg of your battery and bring the other end to the compass and plug it where the regular ground would be..just touch it... if the compass comes back to life, you know it's that... if not you need to change the compass...

If it is the ground, then you can then work on bringing another ground to it or searching the issue of the current non functionning ground.

also make sure to test if voltage is coming to the compass once you have opened the assembly...
Back to top
View user's profile Send private message Visit poster's website
TmacisN11



Joined: 08 Nov 2010
Posts: 5

PostPosted: Thu Nov 11, 2010 2:06 pm    Post subject: Reply with quote

ok so what color wire is ground and power for the harness that connects into the compass/temp display unit that is in the upper console?
Back to top
View user's profile Send private message Send e-mail
fleurys



Joined: 12 May 2009
Posts: 208
Location: Ste-Catherine, QC

PostPosted: Thu Nov 11, 2010 2:59 pm    Post subject: Reply with quote

TmacisN11 wrote:
ok so what color wire is ground and power for the harness that connects into the compass/temp display unit that is in the upper console?


according to the wiring diagram I posted for you, follow like this:

1) the connector on the compass assembly is R4
2) The R4 plug is showed at the bottom.
3) again looking at the wiring diagram, the power's color is G/R (probably means Green/red), but the real usefull info is the wire number to the R4 connector...which is 7 .. So the power connects to the 7th position on the connector
4) the ground connects to position 2 which colors isaid as being B (usually black)..

I gave you everything to troubleshoot this....

S.
Back to top
View user's profile Send private message Visit poster's website
TmacisN11



Joined: 08 Nov 2010
Posts: 5

PostPosted: Thu Nov 11, 2010 10:02 pm    Post subject: Reply with quote

you did and thanks, some people arent used to reading wiring diagrams so you gotta be patient with me. ok
Back to top
View user's profile Send private message Send e-mail
Albah



Joined: 06 Dec 2012
Posts: 1

PostPosted: Thu Dec 06, 2012 3:02 pm    Post subject: Reply with quote

Came across this post, had to make an account.

I just picked up a 98 Pathfinder a few weeks ago. It's been awesome thus far! The compass/temp wasn't working when I first picked it up. I replaced one of the bulbs in the mirror and it started to work again. Sure enough I was driving around this morning and it went out. Bulbs are both okay, Fuse is okay.

I'm going to try the ground wire. If that doesn't work I'll head to the junk yard for a replacement.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    The Nissan Path Forum Index -> 1996-2004 Pathfinder (R50) All times are GMT - 8 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group