2009 Pathfinder

Post a pic of your ride, tell us where you're from, what vehicle your Path replaced, etc etc.

Moderator: volvite

ghostlead509
Posts: 9
Joined: Wed Mar 23, 2022 3:00 pm

2009 Pathfinder

Postby ghostlead509 » Mon Apr 18, 2022 2:12 am

Hello everyone. Recently bought a 2009 Pathy as an off road project. Came here for some advice and help finding the right stuff for it. Had a 2007 GX 470, but the engine finally gave out at 397,634 miles. And since I found an R51 for a great price ($4,000) with 133,000 miles, I figured I'd give it a go. Needed some TLC, which I knew from the start but so far I have replaced the timing chain and fan clutch. Ordered the lift, and probably going to purchase a rear bumper soon. I love her so far and the things I have/want to do to it will be a great learning experience that I am looking forward to with the help of everyone on the forum.

2009 Pathfinder SE 4wd
Attachments
Pathfinder Version.jpg


User avatar
palmerwmd
Site Admin
Posts: 2346
Joined: Tue Jan 31, 2017 4:45 am
Location: Mid Atlantic

Re: 2009 Pathfinder

Postby palmerwmd » Mon Apr 18, 2022 8:45 am

Nice catch!

Looks like you have the same aftermarket headlights I do!
Welcome to Thenissanpath! :D

ghostlead509
Posts: 9
Joined: Wed Mar 23, 2022 3:00 pm

Re: 2009 Pathfinder

Postby ghostlead509 » Mon Apr 18, 2022 3:49 pm

So far I am loving the forum, lots of helpful people. I just wish I had joined sooner, when I replaced the fan clutch I used a non OEM brand I had used on the GX and now I read that everyone says just use the OEM one or it will constantly be on. And mine is constantly on. But at least now I know!

User avatar
palmerwmd
Site Admin
Posts: 2346
Joined: Tue Jan 31, 2017 4:45 am
Location: Mid Atlantic

Re: 2009 Pathfinder

Postby palmerwmd » Thu Apr 21, 2022 8:29 pm

ghostlead509 wrote:
Mon Apr 18, 2022 3:49 pm
So far I am loving the forum, lots of helpful people. I just wish I had joined sooner, when I replaced the fan clutch I used a non OEM brand I had used on the GX and now I read that everyone says just use the OEM one or it will constantly be on. And mine is constantly on. But at least now I know!
I keep learning new stuff on here even after years of membership :D


Return to “New Members, Sound Off!”