P0172

The Gas and Diesel Engines - VQ40De, VK56DE, YD25DDTi, V9X, Transmission, Transfer Case, Oil, Differentials, Axles, Exhaust...

Moderator: volvite

Gn22
Posts: 58
Joined: Wed Dec 18, 2013 11:28 am

P0172

Postby Gn22 » Mon Sep 25, 2023 6:19 pm

Hi, P0172 almost new MAF sensor replaced 05-23 O2 sensor replaced both sides Upstream with NTK 18 months ago. Air filter new. Smoke test and no leak found. When I reset the ECU, the car is running well Any help would be appreciated. THANK YOU.
Attachments
20230925_223036.jpg
20230925_222852.jpg
20230925_222415.jpg


User avatar
VStar650CL
Posts: 532
Joined: Wed Dec 09, 2020 6:19 pm

Re: P0172

Postby VStar650CL » Mon Sep 25, 2023 9:20 pm

That's a very unusual code, it's the opposite of a vacuum leak. The ECM is trying to lean bank1, not rich it. Normally that's an issue with one or more of the injectors, but normally that also means some sort of miss or rough running. Fuel pressure or MAF problems would be affecting both banks. Since you're not getting any of that, my first guess would be that your bank1 A/F Sensor (front O2) is lying to the ECM.

Gn22
Posts: 58
Joined: Wed Dec 18, 2013 11:28 am

Re: P0172

Postby Gn22 » Tue Sep 26, 2023 7:34 pm

OK Thank You, I will replace bank1 A/F Sensor to see what happen.

Gn22
Posts: 58
Joined: Wed Dec 18, 2013 11:28 am

Re: P0172

Postby Gn22 » Sat Oct 14, 2023 5:29 pm

Hi, after 2 weeks that I replaced bank1 A/F Sensor (front O2) with Denso so far so good thank you VStar

User avatar
VStar650CL
Posts: 532
Joined: Wed Dec 09, 2020 6:19 pm

Re: P0172

Postby VStar650CL » Sat Oct 14, 2023 5:40 pm

You're most welcome, happy to help. Happy motoring!


Return to “R51 Engine, Driveline and Powertrain”