CLUNK with Calmini Lift

Topics relating to Lift Kits, Suspension, Steering...

Moderator: volvite

mtcoastie
Posts: 33
Joined: Thu Aug 11, 2011 5:13 pm
Location: Tampa Bay, FL

CLUNK with Calmini Lift

Postby mtcoastie » Mon Nov 10, 2014 2:12 pm

Hey everyone! I have been chasing a clunk in my front end for a while now. I installed the Calmini 5" with Radflo coilovers. This clunk happens when I go over things at lower speeds, like speed bumps and what not, and seems to happen as the struts extend. Here's a list of things I have done trying to fix it: replaced LCA's twice, new inner and outer tie rods, PRG extended UCA's, sway bar bushings, sway bar end links. I am pretty sure that is all I have done thus far, and the clunk is still there. It is such a strong clunk, that sometimes you can feel it in the floorboards. I am not 100% positive if the clunk is causing it, but the powder coat is flaking off of the Calmini lift components, and now a lot of the stuff is starting to rust pretty bad. I am thinking about replacing the CV joints and the wheel bearings next. Just looking for any other ideas anyone might have.


User avatar
patomwazi
Posts: 199
Joined: Thu May 30, 2013 9:59 am
Location: Dubai, UAE

Postby patomwazi » Mon Nov 10, 2014 2:14 pm

maybe location of its attachment point to the chassis is gone?..

mtcoastie
Posts: 33
Joined: Thu Aug 11, 2011 5:13 pm
Location: Tampa Bay, FL

Postby mtcoastie » Mon Nov 10, 2014 2:27 pm

Oh, now that you mention that, I replaced the forward body mounts as well. The engine mounts were done a few years back on warranty as well

User avatar
Captain
Sponsored Member
Posts: 692
Joined: Wed Mar 19, 2008 7:41 pm
Location: S.w. Chicago

Postby Captain » Wed Nov 12, 2014 5:58 am

Check the bolts from the lift to frame. If you're looking powder coating it can be that the coating where attachments are made as well. I had a Superlift 6" on a old Chevy and after some time the coating was coming off and it started to clunk so I tightened all the bolts and it went away. So I just got lazy and welded the lift on

kevinthefro
Posts: 98
Joined: Tue Aug 27, 2013 4:14 pm
Location: Torrance, CA

Postby kevinthefro » Thu Nov 13, 2014 11:18 am

There are a lot of posts here and on newfrontier.org reporting that Radflos clunk. Something to do with the valves and the transition from compression to rebound. There is no fix. I mostly got used to it.

And yes, I too can feel it through the floorboard.

User avatar
NmexMAX
Posts: 796
Joined: Mon Oct 11, 2010 2:35 pm
Location: Northern New Mexico

Postby NmexMAX » Thu Dec 04, 2014 10:16 am

Mine haven't done this yet. Are these the Titan units?

I've got these and they have yet to start clunking.

Image


Return to “R51 Suspension and Steering”

cron