Post repair issues with my 2003. Need help!

Attack of the unibody snatchers! Styling and handling refined or bland? You decide.

Moderator: volvite

captain obvious
Posts: 1
Joined: Sun Jan 10, 2010 8:56 pm

Post repair issues with my 2003. Need help!

Postby captain obvious » Sun Jan 10, 2010 8:58 pm

Hi All! First post....

I own a 2003 Nissan Pathfinder. 103K. Purrs like a kitten. I bought this truck while still living in NY, so it saw lots of moisture and salt - thus some corrosion. Since owning it, i've rack up 50K+ on so it's been through hell.

I had shocks and struts done recently. Thats where the issue started. My rack and pinion busted, so i had that replaced with my 2 front struts and mounts. Front end was aligned. The vehicle runs very smooth, is responsible, etc....

...until i hit a bump. If hitting a sharp bump/dip just right, I'm getting a loud thunking noise coming from both wheel wells. It's not throwing my driving off or anything, but it's loud! Sort of like a metal object is being tossed around in the well/under the hood.

I brought it back to those who did the work and some others and no one seems to be able to figure it out. Either they dont wanna deal with it because it will cost them $ or they simply cannot find the issue.

I am no mechanic, but I should not be hearing this sound. Any help would be appreciated.


User avatar
Tech
Posts: 395
Joined: Mon Mar 16, 2009 2:46 pm

Postby Tech » Thu Jan 14, 2010 10:21 pm

check your sway bar links - common


Return to “1996-2004 Pathfinder (R50)”

cron