Could it be the alternator?

You gotta Love these old VG30E/i powered beasts, raw truck DNA to the core.

Moderator: volvite

Pitapit
Posts: 2
Joined: Thu Sep 23, 2010 2:51 pm

Could it be the alternator?

Postby Pitapit » Thu Sep 23, 2010 2:58 pm

A couple days ago i had my 95 pathfinder parked with the keys on ac listining to music, next thing i know the deck starts flashing on and off, I try and start it and i just hear a repeated clicking. So we jumped it and she was good to go. Got in about 2 hours later and it wouldnt start. So i eneded up buyin a new battery and it was good for 2 days..

Then yesterday as i was driving the deck started flickering again as i pulled into the gas station. Got gas then it wouldnt start again, came back two hours later and it just fired up. Then on the way home goin down a hill it just shut right down, breaks and steering locked up. now it wont start at all. im thinkin alternator?


User avatar
fat_frog
Posts: 85
Joined: Mon Mar 02, 2009 12:18 pm
Location: 19320

Postby fat_frog » Thu Sep 23, 2010 10:08 pm

Sounds like alternator to me, too.

I don't know where you live, but your local auto parts store might be able to check your alternator... I think AutoZone does that for free.

WheatBread
Posts: 148
Joined: Wed Apr 28, 2010 7:08 am
Location: Little Rock, Ar

Postby WheatBread » Fri Sep 24, 2010 6:13 am

have you noticed if all your dash lights come on? When the voltage drops below like 11.5 IIRC all your dash lights should come on, if the battery is new that should indicate your alty is toast

Pitapit
Posts: 2
Joined: Thu Sep 23, 2010 2:51 pm

Postby Pitapit » Sun Sep 26, 2010 3:10 pm

I have no idea what 11.5 IIRC means, i havent noticed anything going on with the dash lights though just the deck and int light.

I just got the alt in and turned the key and im still gettin the repeated clicking so now im really pissed off. What else could it be?

WheatBread
Posts: 148
Joined: Wed Apr 28, 2010 7:08 am
Location: Little Rock, Ar

Postby WheatBread » Mon Sep 27, 2010 5:22 am

11.5 volts; IIRC = If I Remember Correctly

If you ran it with a dead alt then your battery is probably dead too, once the alt goes dead you start sucking all of the juice out of your battery until it's drained, try getting a jump, the alty won't charge the battery without the engine running


Return to “1986-1995 Pathfinder (WD21)”

cron