1994 nissan pathfinder turn signal problems

You gotta Love these old VG30E/i powered beasts, raw truck DNA to the core.

Moderator: volvite

KILOBENTLEY88
Posts: 1
Joined: Sun Nov 13, 2011 10:39 am
Location: charleston

1994 nissan pathfinder turn signal problems

Postby KILOBENTLEY88 » Sun Nov 13, 2011 10:46 am

I have a 1994 nissan pathfinder my turn signals do not work at all when i flip the switch to turn nothing happens, but if i turn my emergency flashers on the lights flash? please help if anyone has ever had this problem i just had a little one and the wifey needs a car to drive but i don't want her to drive with no turn signals. im not good with electrical. all help would be gladly appreciated thanks


Skye
Posts: 12
Joined: Fri Feb 10, 2012 7:37 pm
Location: North Vancouver, Canada

Re: 1994 nissan pathfinder turn signal problems

Postby Skye » Tue Dec 10, 2013 6:12 pm

Did you ever get this issue resolved, have exactly same issue, signals a no go but emergency flasher a-ok

User avatar
shaggyT
Posts: 62
Joined: Thu Nov 28, 2013 10:19 pm
Location: NYC

Re: 1994 nissan pathfinder turn signal problems

Postby shaggyT » Tue Dec 10, 2013 9:19 pm

Skye wrote:Did you ever get this issue resolved, have exactly same issue, signals a no go but emergency flasher a-ok
I'm no expert but could it be a blown fuse or maybe the actual indicator stick thing?

Skye
Posts: 12
Joined: Fri Feb 10, 2012 7:37 pm
Location: North Vancouver, Canada

Postby Skye » Wed Dec 11, 2013 11:30 am

Thanks, Shaggy T, changed out the fuse and did manage to get signals although fuse looked good. Now, though, my left front signal, when turned on, also turns on the right signal parking light. go figure. If you are following me, you're safe as rear one work fine. Assume I may have a ground fault somewhere which could have lead to the demise of original fuse, any ideas anyone???

User avatar
smj999smj
Site Admin
Posts: 5759
Joined: Sun Jan 22, 2012 11:13 pm
Location: Prospect, VA

Postby smj999smj » Wed Dec 11, 2013 12:08 pm

Sounds like you have a shorted bulb somewhere. Check your bulb contacts as they can mushroom over time and cause such shorts.

WheatBread
Posts: 148
Joined: Wed Apr 28, 2010 7:08 am
Location: Little Rock, Ar

Postby WheatBread » Thu Mar 21, 2019 8:26 am

Any resolution to this problem? I am experiencing the same thing.

Ethan
Posts: 1
Joined: Tue Mar 24, 2020 10:36 am
Location: Saskatchewan, Canada

Postby Ethan » Tue Mar 24, 2020 10:38 am

I had this problem on my 92. Took apart apart my steering column and blew all the dust out of the connection. Worked perfectly afterwards.

volox
Posts: 40
Joined: Sat Jan 29, 2011 6:35 pm

Postby volox » Sun Mar 29, 2020 4:28 pm

As Ethan says, that can be a steering column switch problem. Sometimes you can blow the dust out to fix it, other times the contacts are corroded and you either have to disassemble and rebuild the switch or you have to replace it.


Return to “1986-1995 Pathfinder (WD21)”

cron