IPDM issue really ECM relay?

**** PLEASE USE SUBTOPICS BELOW FOR NEW TOPICS ****

Moderator: volvite

CPLTECH
Posts: 222
Joined: Wed Sep 08, 2010 9:30 am
Location: SW Ohio

Postby CPLTECH » Fri Sep 10, 2010 9:28 am

As a former electronic tech that repaired printed circuit boards, but having never removed my own 2006 IPDM board, I will make a few “assumptions” from the above statements.

Yes, relay contacts can get pitted and go bad. However, when the relay was removed & reinstalled then soon thereafter gives problems again, I would suspect defective solder connections on the board to be the culprit. A qualified electronic tech could try to carefully resolder the board with “electrical” solder, not “plumbing acid core” solder. Two problems arise: Some solders are softer than others and will not last. Second, some boards have multi-layered printed wiring that pose difficulty for a good repair. So perhaps that is why Nissan strongly suggests total replacement of the board.

I do appreciate the info given of possible trouble so that should this happen to me I will try to wiggle the relay and hopefully make it home.

Info for the IPDM is found in the Service manual, PG file (Power Supply Circuits), page 25 has the diagram of relay locations.
See: Sticky: Service and other Nissan manuals.

EDIT of 4/2013
Since first reply, I now understand that the maker of the relay had issues during mfg that caused early failure.
Last edited by CPLTECH on Fri Apr 26, 2013 8:11 am, edited 1 time in total.


Npath
Posts: 356
Joined: Wed May 21, 2008 10:20 pm
Location: Vancouver, Canada

Postby Npath » Sun Sep 12, 2010 5:10 pm

What is the part number to replace the IPDM?

koolmw
Posts: 2
Joined: Wed Dec 01, 2010 2:31 pm
Location: Austin, TX

My 2006 Pathfinder problem...

Postby koolmw » Wed Dec 01, 2010 2:44 pm

I am having a very similar problem to what you described. My 2006 pathfinder runs perfect and will all of the sudden stall at low speed within the first few minutes of running. When it does stall it sometimes is hard to start and sometimes starts right away. Once running, it runs perfect. It has 75k miles on it. Also, the speedometer started going wacky on me now. It lurches from time to time at very slow speed too.

I took it to the dealer (never again) and the told me that the timing chain and sprockets need to be replaced at a cost of nearly $3000. Timing chain? It runs perfect when it's not stalling and telling me I'm going 55 mph when I'm going 20 mph.

I talked to several mechanics, not dealer affiliated, that tell me their diagnosis sound wrong and they are trying to rip me off.

I was wondering if this sound similar to your issue and if so, where can I get a relay to fix the problem?

Thanks for posting your info on the forum!

allisojh
Posts: 90
Joined: Sun Oct 17, 2010 6:43 pm

Postby allisojh » Wed Dec 01, 2010 8:34 pm

Recall was listed on Octobr 28 2010 recalling 05-06 Pathfinders to have the ECM replaced for free. Check the recalls for all of the info. Sounds like what is being listed on this thread.

Recall #85853

koolmw
Posts: 2
Joined: Wed Dec 01, 2010 2:31 pm
Location: Austin, TX

ECM Relay Recall

Postby koolmw » Mon Dec 06, 2010 1:53 pm

I just got off the phone with Nissan USA and confirmed that my 2006 Pathy is included in this recall. I'm scheduled to have it done tomorrow. Finally!

NHTSA CAMPAIGN ID Number: 10V517000


Component: ENGINE AND ENGINE COOLING
Manufacturer: NISSAN NORTH AMERICA, INC.
Potential Number of Units Affected: 747480

Year: 2006
Make: Nissan
Model: Pathfinder
Manufactured
from: 2004-06-23
to: 2006-06-16
Recall Date: 2010-10-28

Summary:

NISSAN IS RECALLING CERTAIN MODEL YEAR 2004-2006 ARMADA, TITAN, INFINITI QX56 AND MODEL YEAR 2005-2006 FRONTIER, PATHFINDER AND XTERRA VEHICLES. THE INTELLIGENT POWER DISTRIBUTION MODULE (IPDM) ASSEMBLY CONTAINS AN ENGINE CONTROL MODULE (ECM) RELAY THAT HAS A DIODE FOR ELECTRICAL CURRENT NOISE REDUCTION. THE ECM RELAY MAY ALLOW SILICON VAPOR TO FORM AND, OVER TIME, THE SILICON EVAPORATES FROM THE DIODE MOLDING WHICH CAUSES SILICON OXIDE TO DEVELOP ON THE ECM RELAY CONTACT DUE TO ARCING.

THIS COULD CAUSE ENGINE STALLING INCREASING THE RISK OF A CRASH.

DEALERS WILL REPLACE THE ECM RELAY INSIDE THE IPDM ASSEMBLY. THIS SERVICE WILL BE PERFORMED FREE OF CHARGE. THE SAFETY RECALL IS EXPECTED TO BEGIN DURING DECEMBER 2010. OWNERS MAY CONTACT NISSAN AT 1-800-647-7261.

frustrated
Posts: 1
Joined: Tue Sep 06, 2011 9:42 am
Location: california

2003 pathfinder

Postby frustrated » Tue Sep 06, 2011 10:02 am

I have a 2003 pathfinder 4wd v6. Having some strange issues. Occasionally th vehicle running fine then after I come to stop at light then try to go the motor or tranny does not respond to pedal being pushed but if i put it in park or neutral itreva fine. Also something is draining my batt. After it sits for awhile it will be fine for a few days. I've done some research and retrieved the codes. P1456 small evap leak and p0731 gear 1 ratio incorrect. That one confuses me. Ratio can't change. Baught a manual and started teari.g into it to change tranny fluid and make aome checks of sensors and wiring and such. While doing this I started to hear a constant click coming from the ecm ir ipdm white plastic box under steering column.thw clixking relay could be draining batt but this is the first I've heard it. Not sure what to do now. Any help or info greatly appreciated. Live in mountains snow coming soon and this is our only 4wd vehicle. Need to fix fast and as cheap as lossible. Thanks

AngryPath
Posts: 3
Joined: Sat Sep 10, 2011 7:01 am
Location: New York

ECM IPDM

Postby AngryPath » Sat Sep 10, 2011 7:08 am

So has the PC068 ECM recall solved most of the electrical problems ? A week after I bent over to have the tranny and radiator done, I seem to be having the relay issue.

AngryPath
Posts: 3
Joined: Sat Sep 10, 2011 7:01 am
Location: New York

Postby AngryPath » Mon Sep 12, 2011 4:30 pm

3 days since my truck was towed in. 4 Requests to do the ECM recall. Svc. advisor thinks its my aftermarket Viper alarm which has never given me any problems.

A rep from regional was supposed to contact me regarding this issue. No call from anyone today. :evil: :evil: :evil:

Find me on twitter @AngryPath

User avatar
eieio
Sponsored Member
Posts: 1830
Joined: Fri Jul 17, 2009 6:42 am
Location: Prescott, Az.

Postby eieio » Wed Jan 11, 2012 9:09 pm

cater wrote:I can tell you that there is a technical notice NOT to service or attempt to service IPDM parts. :lol:


Daily tell you a proverb

An apple a day keeps the doctor away.
------------------------------------------------------------------------------------
trumpet wedding dresses|evening dresses|mermaid wedding dresses|junior bridesmaid dresses
this SPAM needs canning!

balicia85
Posts: 5
Joined: Thu Apr 25, 2013 3:18 pm
Location: allen

Postby balicia85 » Thu Apr 25, 2013 4:02 pm

Hi, my pathfinder wont start, called the nissan, they said it was not part of the recall but the ecm had been replaced in 2012... I just bought this used 4 months ago it is 2006... it is not spitting any codes .. Died while i was driving then wouldnt start... trying to turn over but wont actually start... please help!!

djbit
Posts: 24
Joined: Sun Feb 15, 2009 10:53 am

Postby djbit » Wed Nov 13, 2013 3:30 pm

balicia85 wrote:Hi, my pathfinder wont start, called the nissan, they said it was not part of the recall but the ecm had been replaced in 2012... I just bought this used 4 months ago it is 2006... it is not spitting any codes .. Died while i was driving then wouldnt start... trying to turn over but wont actually start... please help!!
Mine had similar a issue and it ended up being the engine knock sensor. I bought the sensor at Autozone. Also, does your dash blink wildy? If so, it could be your IPDM module again. You can now buy just the bad relay for like 3 bucks (http://www.courtesyparts.com/).

Good luck.

acberg7
Posts: 1
Joined: Thu Dec 12, 2013 2:39 pm

HAPPENED TO ME TOO!!! :(

Postby acberg7 » Thu Dec 12, 2013 2:43 pm

[quote="balicia85"]Hi, my pathfinder wont start, called the nissan, they said it was not part of the recall but the ecm had been replaced in 2012... I just bought this used 4 months ago it is 2006... it is not spitting any codes .. Died while i was driving then wouldnt start... trying to turn over but wont actually start... please help!![/quote]



THATS THE SAME THING THAT HAPPENED TO ME ALMOST A WEEK AGO AND THE DEALER SHIP ITS AT IS TELLING ME THE ECM & TCM ARE NEEDING TO BE REPLACED FOR $2800.00 .. I SAW THE RECALL ON THE "ECM RELAY" BUT NOTHING FOR JUST THE "ECM" .. I DONT KNOW WHAT TO DO, I'M NOT PAYING $2800.00


Return to “2005-2012 Pathfinder (R51)”