IPDM Question

**** PLEASE USE SUBTOPICS BELOW FOR NEW TOPICS ****

Moderator: volvite

BamaRed
Posts: 18
Joined: Thu Jan 03, 2008 8:47 am

IPDM Question

Postby BamaRed » Mon Oct 04, 2010 7:07 am

Hey guys,

My Path has started to give me the symptoms of what I think is a IPDM failure. Here is what she is doing:

Runs great, take it for about a five mile ride, stop.
Cut if off, and it does not want to start back. Pull the key out of the ignition.Put key back in and it cranks, but almost is like it is missing, real rough and shaky.Cut if off, pull the key, put it back in, sometimes it cranks right up just like nothing happened, other times get the same problem and have to do it a few times to get it to crank.Also, does not do it consistently, sometime will run great and then all of a sudden. This just started this last week.

I pull the IPDM last night and swapped the rear window defroster relay with the ECM relay to see if it goes away after doing some research online.

Would you guys agree that this sounds like the IPDM failure issue? Just want some backup before I plunk down $150 for a board at Courtesy.

Thanks!
Hunter


User avatar
pawjr74
Posts: 597
Joined: Tue Mar 23, 2010 9:11 am
Location: Gilbert, AZ

Postby pawjr74 » Mon Oct 04, 2010 9:27 am

Yes. Eventually it will just shut off on you and leave you stranded in the middle of the road like mine did. Get it fixed before it's too late.

User avatar
deermjd
Posts: 459
Joined: Mon Jul 19, 2010 7:24 pm
Location: Birmingham, Alabama

Postby deermjd » Mon Oct 04, 2010 9:29 am

You seem to be having the same symptoms I had when I had issues with my IPDM. Mine would only crank sometimes and when it did it idled very rough. How does your car run after you swapped the relays?

I was able to find an exact replacement ECM relay from a member of a Titan forum. It seems my issue was just a bad ECM relay. I have driven at least a month and ~2000 miles since replacing the relay and have had not had any more problems.

So you might want to look into that before you replace the whole IPDM.

User avatar
JAHBLESSINGS
Sponsored Member
Posts: 1400
Joined: Mon Oct 13, 2008 1:36 pm
Location: 90 DEGREES FLORIDA

Postby JAHBLESSINGS » Mon Oct 04, 2010 10:43 am

you have a part number for the relay?

BamaRed
Posts: 18
Joined: Thu Jan 03, 2008 8:47 am

Postby BamaRed » Mon Oct 04, 2010 11:50 am

I was under the impression you needed to replace the whole board, not just the relay since the board is damaging the relays.

I am going to go ahead and order the whole board and just hold on to the old board in case I need some relays in the future.

Thanks for the confirmation guys, hopefully this takes care of it...

For now! :P

jpar
Posts: 9
Joined: Sat Oct 02, 2010 6:38 pm
Location: central nj

Postby jpar » Mon Oct 04, 2010 6:05 pm

Is the replacement IPDM a new design or does is just fail again? I'm thinking of buying one and keeping it in the rear storage bin until this happens to mine.

nightstalker 6
Posts: 13
Joined: Sun Apr 25, 2010 7:51 pm

Postby nightstalker 6 » Tue Oct 05, 2010 5:16 am

the external design is old, the internal esign is new. NOTE: There are two IPDMs listed for your vehicle. One has the locking ring on it, the other does not. Buy the one without, then transfer the ring from the old to the new. It saved 25.00 when i did that.

User avatar
pawjr74
Posts: 597
Joined: Tue Mar 23, 2010 9:11 am
Location: Gilbert, AZ

Postby pawjr74 » Tue Oct 05, 2010 6:33 am

Does anybody have any info on what components the IPDM controls?

Would it send power to the A/C heater control?

BamaRed
Posts: 18
Joined: Thu Jan 03, 2008 8:47 am

Postby BamaRed » Thu Oct 07, 2010 7:40 am

Did the swap out last night with the new one from Courtesy. Everything ran great this morning. Will post back in a few weeks if all is well. I have not noticed the problem since I swapped the relays, but wanted to replace the unit just to be safe.

Citcope
Posts: 127
Joined: Wed Jul 09, 2008 3:17 pm
Location: Northern Virginia

Postby Citcope » Thu Oct 07, 2010 3:21 pm

jpar wrote:Is the replacement IPDM a new design or does is just fail again? I'm thinking of buying one and keeping it in the rear storage bin until this happens to mine.
Thats what u did. Havent had to use mine yet and hopefully wont. I have 89000 on my path and no symptoms.


Return to “2005-2012 Pathfinder (R51)”

cron