Service Engine Soon Light......CODE's UPDATED

**** PLEASE USE SUBTOPICS BELOW FOR NEW TOPICS ****

Moderator: volvite

User avatar
Kami
Posts: 243
Joined: Wed May 12, 2010 8:59 pm
Location: Toroto, ON

Service Engine Soon Light......CODE's UPDATED

Postby Kami » Sun Jan 16, 2011 7:03 pm

Is it possible to turn this off manualy?

Thanks
Last edited by Kami on Sun Jan 23, 2011 1:57 am, edited 1 time in total.


User avatar
disallow
Site Admin
Posts: 2807
Joined: Wed Aug 13, 2008 9:02 am
Location: Winnipeg, Canada

Postby disallow » Sun Jan 16, 2011 8:56 pm

Yep. Disconnect the battery. Otherwise get a cheap code reader or go to Partsource and borrow one of theirs.

Do you know what the code is?

User avatar
mar1
Sponsored Member
Posts: 1041
Joined: Fri Jun 19, 2009 9:08 am
Location: Dubai
Contact:

Postby mar1 » Mon Jan 17, 2011 12:37 am

or alternatively use a BFH to turn it off permanently.. :wink:

User avatar
pawjr74
Posts: 597
Joined: Tue Mar 23, 2010 9:11 am
Location: Gilbert, AZ

Postby pawjr74 » Mon Jan 17, 2011 10:00 am

You probably need to replace 1 or both cats, the IPDM, or the fuel sending unit. (I've done all that to mine)

Seriously though why do you think it came on?

User avatar
disallow
Site Admin
Posts: 2807
Joined: Wed Aug 13, 2008 9:02 am
Location: Winnipeg, Canada

Postby disallow » Mon Jan 17, 2011 10:01 am

pawjr74 wrote:You probably need to replace 1 or both cats, the IPDM, or the fuel sending unit. (I've done all that to mine)

Seriously though why do you think it came on?
Not necessarily. In summer I had the nagging P0455 code, Gross evap leak. Its the evap valve that I need to get around to replacing. I just keep resetting it.

User avatar
Kami
Posts: 243
Joined: Wed May 12, 2010 8:59 pm
Location: Toroto, ON

Postby Kami » Mon Jan 17, 2011 8:04 pm

pawjr74 wrote:You probably need to replace 1 or both cats, the IPDM, or the fuel sending unit. (I've done all that to mine)

Seriously though why do you think it came on?
Those generally covered under the warantee right? I have the extended. No idea what the code is. I ask casue i want to reset it before i drive all the way to bufflo from toronto :( (2hr drive) casue bought it in the states and extended warantee works there..lol

for the battery reset....do i need positive and negative both off? or can i just disconnect the positive and put it back on.


Thanks in advance

driftedoffroad
Posts: 56
Joined: Tue Apr 20, 2010 10:13 am
Location: NJ

Postby driftedoffroad » Mon Jan 17, 2011 8:40 pm

why would you want to reset the light if your bringing it for service? They would need to check the code to see whats wrong in order to fix it :)

User avatar
BMXPath
Posts: 360
Joined: Fri Oct 19, 2007 7:55 am
Location: Texas!

Postby BMXPath » Tue Jan 18, 2011 6:43 am

for the battery reset....do i need positive and negative both off? or can i just disconnect the positive and put it back on.

Thanks in advance
You dont need to disconnect both. Disconnect the negative though, not the positive.

webmastir

Postby webmastir » Tue Jan 18, 2011 9:45 am

pawjr74 wrote:You probably need to replace 1 or both cats, the IPDM, or the fuel sending unit. (I've done all that to mine)
shit, you better hope you don't have to replace the cats (if you're not under warranty). those get really expensive. go to autozone(any autoparts store) and get your error code read. write it down & post it here. might be something simple you can resolve yourself

deezx5
Posts: 96
Joined: Tue Mar 02, 2010 7:59 am

Postby deezx5 » Tue Jan 18, 2011 12:37 pm

Dont cats have an extended federal warranty? I think its 8 or 9 years.

User avatar
HillbillyJake
Posts: 352
Joined: Fri Dec 12, 2008 8:55 pm
Location: Pitcairn Pa.

Postby HillbillyJake » Wed Jan 19, 2011 6:42 am

8 year 80k.

User avatar
Kami
Posts: 243
Joined: Wed May 12, 2010 8:59 pm
Location: Toroto, ON

Postby Kami » Wed Jan 19, 2011 8:27 pm

sweet thanks for info till now......

I will go to autozone tomorrow to getthe code read on friday, casue my dealer appointment is till next friday!!?! damn busy in the winter.

But I noticed something else, before the "Service Engine Soon" light came on, when my tires would slip due to snow/slush on the road it would flash slip on the dash board to let me know....but now it doesnt!! Is that normal that it would stop flashing when the "service engine soon" light engages? or is that the reason my the "service engline soon" light is on!

LOL oh man....

Thanks guys in advance

User avatar
2008PatherfinderS
Posts: 65
Joined: Tue Sep 02, 2008 6:15 am

Postby 2008PatherfinderS » Thu Jan 20, 2011 5:24 am

Do not erase the code if taking it in for service. When you erase the code, the dealer will not be able to extract the code until the light comes on again.

User avatar
Kami
Posts: 243
Joined: Wed May 12, 2010 8:59 pm
Location: Toroto, ON

Postby Kami » Sun Jan 23, 2011 2:01 am

Hey guys so got my bro's friend, friend (owns his own shop) to check the code. :D

1) P2A03 sensor circuit range performance bank 2 sensor 1

2) P0158 02 circuit high bank 2 sensor 2


they seam to be soem sensor stuff, anyone know details and what it pertains to?

Thanks in advance!!

User avatar
2008PatherfinderS
Posts: 65
Joined: Tue Sep 02, 2008 6:15 am

Postby 2008PatherfinderS » Wed Jan 26, 2011 5:06 pm

Most likely failed Oxygen Sensors.


Return to “2005-2012 Pathfinder (R51)”