Sooo simple

Any topics related to 2005-2012 R51

Moderator: volvite

Knightro
Posts: 17
Joined: Sat Jan 25, 2014 6:37 am
Location: South Jersey

Sooo simple

Postby Knightro » Mon Mar 31, 2014 1:59 pm

I can't believe how long I've put up with that annoying squeak/chirping sound coming from my truck. I finally got around to trying the electrical tape on the hood latch. That'll never work, too easy I said. Needless to say, it worked.

Thanks to all who have suggested that fix. I don't know what would have possessed someone to try that in the first place but it sure does work. Thanks again!


User avatar
doctahjones
Posts: 844
Joined: Tue Nov 16, 2010 11:08 am
Location: aurora, co

Postby doctahjones » Mon Mar 31, 2014 8:33 pm

yup, crazy huh? but such and annoying squeak!

User avatar
NVSteve
Sponsored Member
Posts: 1985
Joined: Thu Feb 01, 2007 11:27 am
Location: Salt Lake City

Re: Sooo simple

Postby NVSteve » Tue Apr 01, 2014 8:47 am

Knightro wrote:I can't believe how long I've put up with that annoying squeak/chirping sound coming from my truck. I finally got around to trying the electrical tape on the hood latch. That'll never work, too easy I said. Needless to say, it worked.

Thanks to all who have suggested that fix. I don't know what would have possessed someone to try that in the first place but it sure does work. Thanks again!
It took me quite a while of being seriously annoyed before someone suggested & it took care of the problem. I was skeptical as well, because it didn't sound like it was coming from that are of the hood at all, but rather somewhere in the passenger side suspension. Of all the things I've done/added to the Pathfinder, 6" of electrical tape has been the most satisfying by far.

Goliat6288
Posts: 42
Joined: Fri Mar 07, 2014 12:46 pm
Location: Pittsburgh, PA

Re: Sooo simple

Postby Goliat6288 » Tue Apr 01, 2014 9:13 am

NVSteve wrote: It took me quite a while of being seriously annoyed before someone suggested & it took care of the problem. I was skeptical as well, because it didn't sound like it was coming from that are of the hood at all, but rather somewhere in the passenger side suspension. Of all the things I've done/added to the Pathfinder, 6" of electrical tape has been the most satisfying by far.
now that you mention a squeak from the passenger side suspension, was it all the time, during small bumps on the road or speed bumps? i get a small squeak going over speed bumps once in a while.

User avatar
smj999smj
Site Admin
Posts: 5811
Joined: Sun Jan 22, 2012 11:13 pm
Location: Prospect, VA

Postby smj999smj » Mon Apr 07, 2014 10:50 pm

The squeak isn't just a Pathfinder issue. I recently worked on a 2007 Maxima that had the same squeak. Electrical tape fixed that, as well!


Return to “R51 General Chat”