2009 Lifeted wtih Ranch Quick Lift

Topics relating to Lift Kits, Suspension, Steering...

Moderator: volvite

pathinAR
Posts: 4
Joined: Wed Sep 25, 2013 9:04 am

2009 Lifeted wtih Ranch Quick Lift

Postby pathinAR » Fri Mar 14, 2014 11:06 am

I purchased the Rancho quick lift and put on the largest tire I could squeeze in. Looks great but rides like a boat at higher speeds. Sometimes, around 80 mph, it starts rocking so bad it makes passengers scared. Scares me too. Really annoying. Anyone else have this issue? Suggestions?


fleurys
Posts: 286
Joined: Tue May 12, 2009 5:03 am
Location: Ste-Catherine, QC
Contact:

Postby fleurys » Fri Mar 14, 2014 11:11 am

Did you check with rancho to know what they have to say ??

User avatar
akley88
Posts: 449
Joined: Sun Mar 03, 2013 1:45 pm
Location: United States

Postby akley88 » Fri Mar 14, 2014 1:05 pm

what pressure are you running in the tires and what do you have the struts set to?

User avatar
BigEz
Posts: 131
Joined: Wed Jul 31, 2013 8:07 pm
Location: Houston, Texas

Postby BigEz » Fri Mar 14, 2014 4:11 pm

Did you re-align the rear wheels? If not, do! Lifting can cause your rear end to become out of alignment. In my case, it was unsafe to drive above 50mph.

Not all big box shops can do rear wheel alignment properly... Also, you should invest $100 in a set of airbags (Airlift). They will reduce rear end sway.

Grumpah
Moderator
Posts: 178
Joined: Wed Nov 20, 2013 2:50 pm
Location: Fairfield County, Connecticut

Postby Grumpah » Sun Mar 16, 2014 6:05 am

Moderator - move this post to R51.

User avatar
volvite
Sponsored Member
Posts: 2180
Joined: Wed Feb 16, 2011 5:06 pm
Location: Hill AFB, Utah West Point UT

Postby volvite » Tue Mar 18, 2014 10:57 pm

JayArras wrote:Moderator - move this post to R51.
C/W

User avatar
iheartmypathy
Posts: 157
Joined: Sat Apr 27, 2013 5:17 pm
Location: Southern NH

Postby iheartmypathy » Wed Mar 19, 2014 5:11 pm

I feel your pain man... I've got the same exact issue; and your right, going 80 mph and having that thing rock the way it does... its scary. I've done a ton of research on this issue and here is a good thread to check out:

http://www.thenissanpath.com/viewtopic. ... =body+roll


i had the cam bolts replaced a few months back along with an alignment and it fixed it for a while... but over the last few weeks its back with a vengeance. no bueno.


Return to “R51 Suspension and Steering”